#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?:(?:\+|00)32\h?(?:\(0\)\h?)?|0)(?:4(?:60|[789]\d)/?(?:\h?\d{2}\.?){2}\h?\d{2}|(?:\d/?\h?\d{3}|\d{2}[/-]?\h?\d{2})(?:\.?\h?\d{2}){2}))(?!\S)"
Local $sString = "OK 01/07 - 31/07 " & @CRLF & _
"OK 0487207339" & @CRLF & _
"OK +32487207339" & @CRLF & _
"OK 01.07.2016" & @CRLF & _
"OK +32 (0)16 89 44 77" & @CRLF & _
"OK 016894477" & @CRLF & _
"OK 003216894477" & @CRLF & _
"OK +3216894477" & @CRLF & _
"OK 016/89.44.77" & @CRLF & _
"OK +32 16894477" & @CRLF & _
"OK 0032 16894477" & @CRLF & _
"OK +32 16/894477" & @CRLF & _
"NOK +32 16-894477 (this should match)" & @CRLF & _
"OK 0479/878810" & @CRLF & _
"NOK 20150211-0001731015-1 (this shouldn't match)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")