re = /(?:(?:(?:\+|00)32\h?(?:\(0\)\h?)?|0)(?:4(?:60|[789]\d)\/?(?:\h?\d{2}\.?){2}\h?\d{2}|(?:\d\/?\h?\d{3}|\d{2}[\/-]?\h?\d{2})(?:\.?\h?\d{2}){2}))(?!\S)/
str = 'OK 01/07 - 31/07
OK 0487207339
OK +32487207339
OK 01.07.2016
OK +32 (0)16 89 44 77
OK 016894477
OK 003216894477
OK +3216894477
OK 016/89.44.77
OK +32 16894477
OK 0032 16894477
OK +32 16/894477
NOK +32 16-894477 (this should match)
OK 0479/878810
NOK 20150211-0001731015-1 (this shouldn\'t match)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end