package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\n`)
var str = `!can
!no
!of
!будут`
var substitution = ", "
fmt.Println(re.ReplaceAllString(str, substitution))
}