$re = '/^(?:\d{8,}|\d{2,3}-\d{6,})$/m';
$str = '1-22334455
12345678
1234567890
12-123456
123-1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);