// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d{8,}|\d{2,3}-\d{6,})$").unwrap();
let string = "1-22334455
12345678
1234567890
12-123456
123-1234567";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}