$re = '/(?<=href=")(?:[\w-]+\/?)*/';
$str = ' href="katalog/koshelki-i-klatchi/muzhskaya-sumka-planshet-polo-optom1" a href="katalog/koshelki/kozhanaya-sumka-jeep-optom1"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);