import re
regex = re.compile(r"(?<=href=\")(?:[\w-]+\/?)*")
test_str = " href=\"katalog/koshelki-i-klatchi/muzhskaya-sumka-planshet-polo-optom1\" a href=\"katalog/koshelki/kozhanaya-sumka-jeep-optom1\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")