#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/?[S])|(\,)|([A-Z]\~[A-Z])|([A-Z]\-[A-Z]$)|([A-Z]\/[A-Z])|([A-Z]{2,}$)"
Local $sString = "60-B-1230S" & @CRLF & _
"60-B-1230ABCDEF" & @CRLF & _
"60-B-1230A-F" & @CRLF & _
"60-B-1230A/F" & @CRLF & _
"60-B-1230A~H,0290A~H" & @CRLF & _
"35-K-0101A/B,0201A/B,0301A/B" & @CRLF & _
"35-E-0102A~C, 0202A~C, 0302A~C" & @CRLF & _
"35-E-0103A~H, 0203A~H, 0303A~H" & @CRLF & _
"35-E-0101A/B, 0201A/B, 0301A/B" & @CRLF & _
"35-E-0104A/B, 0204A/B, 0304A/B" & @CRLF & _
"35-P-0101A/B, 0201A/B, 0301A/B" & @CRLF & _
"35-P-0102A/B, 0202A/B, 0302A/B" & @CRLF & _
"35-P-0103A/B, 0203A/B, 0303A/B" & @CRLF & _
"35-P-0104A/B, 0204A/B, 0304A/B" & @CRLF & _
"35-P-0105A/B, 0205A/B, 0305A/B" & @CRLF & _
"35-P-0106/S, 0206, 0306" & @CRLF & _
"35-P-0107/S, 0207, 0307" & @CRLF & _
"35-P-0109A/B, 0209A/B, 0309A/B" & @CRLF & _
"35-P-0111A/B" & @CRLF & _
"35-P-0401A/B" & @CRLF & _
"92-P-0101A/B" & @CRLF & _
"35-V-0108, 0208, 0308" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")