import re
regex = re.compile(r"(\/?[S])|(\,)|([A-Z]\~[A-Z])|([A-Z]\-[A-Z]$)|([A-Z]\/[A-Z])|([A-Z]{2,}$)", flags=re.MULTILINE)
test_str = ("60-B-1230S\n"
"60-B-1230ABCDEF\n"
"60-B-1230A-F\n"
"60-B-1230A/F\n"
"60-B-1230A~H,0290A~H\n"
"35-K-0101A/B,0201A/B,0301A/B\n"
"35-E-0102A~C, 0202A~C, 0302A~C\n"
"35-E-0103A~H, 0203A~H, 0303A~H\n"
"35-E-0101A/B, 0201A/B, 0301A/B\n"
"35-E-0104A/B, 0204A/B, 0304A/B\n"
"35-P-0101A/B, 0201A/B, 0301A/B\n"
"35-P-0102A/B, 0202A/B, 0302A/B\n"
"35-P-0103A/B, 0203A/B, 0303A/B\n"
"35-P-0104A/B, 0204A/B, 0304A/B\n"
"35-P-0105A/B, 0205A/B, 0305A/B\n"
"35-P-0106/S, 0206, 0306\n"
"35-P-0107/S, 0207, 0307\n"
"35-P-0109A/B, 0209A/B, 0309A/B\n"
"35-P-0111A/B\n"
"35-P-0401A/B\n"
"92-P-0101A/B\n"
"35-V-0108, 0208, 0308\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")