import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/(media/catalog/product/cache)/\\d+/thumbnail/(\\d+x\\d+)/[a-z0-9]+/(\\S+)";
final String string = "/media/catalog/product/cache/1/thumbnail/543x403/db978388cfd007780066eaab38556cef/l/e/legal_slide01.jpg\n"
+ "# check if match with above:\n"
+ "/pub/media/catalog/product/cache/543x403/l/e/legal_slide01.jpg\n\n"
+ "/media/catalog/product/cache/1/thumbnail/543x403/db978388cfd007780066eaab38556cef/n/u/number1.png\n"
+ "# check if match with above:\n"
+ "/pub/media/catalog/product/cache/543x403/n/u/number1.png";
final String subst = "/pub/$1/$2/$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}