re = /^\/(media\/catalog\/product\/cache)\/\d+\/thumbnail\/(\d+x\d+)\/[a-z0-9]+\/(\S+)/m
str = '/media/catalog/product/cache/1/thumbnail/543x403/db978388cfd007780066eaab38556cef/l/e/legal_slide01.jpg
# check if match with above:
/pub/media/catalog/product/cache/543x403/l/e/legal_slide01.jpg
/media/catalog/product/cache/1/thumbnail/543x403/db978388cfd007780066eaab38556cef/n/u/number1.png
# check if match with above:
/pub/media/catalog/product/cache/543x403/n/u/number1.png'
subst = '/pub/$1/$2/$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result