const regex = new RegExp('^[a-zA-Zа-яА-Я ]{1,50}$', 'i')
const str = `Новый прgоеdfggкт`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}