$re = '@^[a-zA-Zа-яА-Я ]{1,50}$@i';
$str = 'Новый прgоеdfggкт';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);