package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<((?:[^<>]+|(?R))*+)>`)
var str = `< 111 < 222> <333 <444> 555> 666> <777> <888>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}