$re = '/<((?:[^<>]+|(?R))*+)>/';
$str = '< 111 < 222> <333 <444> 555> 666> <777> <888>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);