$re = '/([\w\.-]+)@(\g<1>)/m';
$str = 'info@apple.com
enoch.night@gmail.com
eel_ling.high@gmail.com
tt-ing@kaa_.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);