re = /([\w\.-]+)@(\g<1>)/m
str = 'info@apple.com
enoch.night@gmail.com
eel_ling.high@gmail.com
tt-ing@kaa_.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end