package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+(?: \w+)+$`)
var str = `abc 123 456
abc 123 456
xyz 123 999
xyz 123 999 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}