$re = '/^\w+(?: \w+)+$/m';
$str = 'abc 123 456
abc 123 456
xyz 123 999
xyz 123 999 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);