const regex = /\[#baz\].*?\[\/baz\](*SKIP)(*FAIL)|\[[^\]]*\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[#baz\\].*?\\[\\\/baz\\](*SKIP)(*FAIL)|\\[[^\\]]*\\]', 'gm')
const str = `Text text text [foo] text text text
Text text text [bar] text text text
Text text text [#baz] [nope] [/baz] text text text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}