re = /\[#baz\].*?\[\/baz\](*SKIP)(*FAIL)|\[[^\]]*\]/m
str = 'Text text text [foo] text text text
Text text text [bar] text text text
Text text text [#baz] [nope] [/baz] text text text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end