package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:#|\$HEX\[|\$)(.*)(?:#|\$|\])$`)
var str = `#слово#
#второе слово#
$1$
$HEX[еще слова]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}