re = /^(?:#|\$HEX\[|\$)(.*)(?:#|\$|\])$/m
str = '#слово#
#второе слово#
$1$
$HEX[еще слова]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end