using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(2[0-9]{3})-([01][0-9])-([0123][0-9])";
string input = @"2018-10-18
2018-1-1
2018-12-31
2018-01-01
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}