package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(2[0-9]{3})-([01][0-9])-([0123][0-9])`)
var str = `2018-10-18
2018-1-1
2018-12-31
2018-01-01
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}