$re = '/(?<=\s|^)(?(?=\$\w+\.\w*\.\w*)|\$\w[\w.]{1,8}\w)(?=[\s]|$)/m';
$str = '$aaa.aaa $bb4 $ccccccccccc $$fff $.dddd $gg..ggf $asd. $a.sa. $x';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);