re = /(?<=\s|^)(?(?=\$\w+\.\w*\.\w*)|\$\w[\w.]{1,8}\w)(?=[\s]|$)/m
str = '$aaa.aaa $bb4 $ccccccccccc $$fff $.dddd $gg..ggf $asd. $a.sa. $x'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end