#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)Host\s+host2\s.*?IdentityFile\s+(?<identity>\S+)"
Local $sString = "Host host1" & @CRLF & _
" HostName 192.168.1.2" & @CRLF & _
" User user" & @CRLF & _
" Port 22" & @CRLF & _
" IdentityFile ~/.ssh/host1" & @CRLF & _
"" & @CRLF & _
"Host host2" & @CRLF & _
" HostName 192.168.1.3" & @CRLF & _
" User user" & @CRLF & _
" Port 22" & @CRLF & _
" IdentityFile ~/.ssh/host2" & @CRLF & _
"" & @CRLF & _
"Host host3" & @CRLF & _
" HostName 192.168.1.4" & @CRLF & _
" User user" & @CRLF & _
" Port 22" & @CRLF & _
" IdentityFile ~/.ssh/host3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")