import re
regex = re.compile(r"Host\s+host2\s.*?IdentityFile\s+(?<identity>\S+)", flags=re.DOTALL)
test_str = ("Host host1\n"
" HostName 192.168.1.2\n"
" User user\n"
" Port 22\n"
" IdentityFile ~/.ssh/host1\n\n"
"Host host2\n"
" HostName 192.168.1.3\n"
" User user\n"
" Port 22\n"
" IdentityFile ~/.ssh/host2\n\n"
"Host host3\n"
" HostName 192.168.1.4\n"
" User user\n"
" Port 22\n"
" IdentityFile ~/.ssh/host3")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")