import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^=\\-\\v]+)\\v[\\-=]+";
final String string = "test\n"
+ "test2\n"
+ "test3\n"
+ "test\n"
+ "====\n"
+ "test4\n"
+ "=====\n\n"
+ "test5\n"
+ "------";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}