re = /([^=\-\v]+)\v[\-=]+/m
str = 'test
test2
test3
test
====
test4
=====
test5
------'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end