using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|.*[^0-9])[0-9]{16}(?:$|[^0-9].*$)";
string input = @"abcdef2222333344445555
22223333444455552222333344445555abcdef
abcdef22223333444455552222333344445555";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}