const regex = /(?:^|.*[^0-9])[0-9]{16}(?:$|[^0-9].*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|.*[^0-9])[0-9]{16}(?:$|[^0-9].*$)', 'g')
const str = `abcdef2222333344445555
22223333444455552222333344445555abcdef
abcdef22223333444455552222333344445555`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}