using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^*]+|\*(?!\d))+(\*[0-9]+\s?)+";
string input = @"Just some blablabla with some notes on the end *1 *2";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}