$re = '/([^*]+|\*(?!\d))+(\*[0-9]+\s?)+/';
$str = 'Just some blablabla with some notes on the end *1 *2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);