$re = '/(?:^listings\/view\/)(?:.*)-(\d+)(?!.*\d)(?:\.html)$/m';
$str = 'listings/view/5330-carmel-crest-lane-charlotte-nc-homes-for-sale-3530458.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);