$re = '/(?<=<div\ class="h1">)?<\/div>/m';
$str = '"текст <div class="h1"><u>Заголовок</u></div> текст" </div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);