re = /(?<=<div\ class="h1">)?<\/div>/m
str = '"текст <div class="h1"><u>Заголовок</u></div> текст" </div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end