#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^foo\/(login$|(?!login).*?(?=[gs]et))([gs]et)?$"
Local $sString = "foo/" & @CRLF & _
"foo/login" & @CRLF & _
"foo/login/get" & @CRLF & _
"foo/sadas/set" & @CRLF & _
"foo/sadasf/asd" & @CRLF & _
"foo/blabla/get"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")