$re = '/^foo\/(login$|(?!login).*?(?=[gs]et))([gs]et)?$/m';
$str = 'foo/
foo/login
foo/login/get
foo/sadas/set
foo/sadasf/asd
foo/blabla/get';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);