#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^.](?=\.)"
Local $sString = "......... A" & @CRLF & _
"1........ B" & @CRLF & _
"112...... C" & @CRLF & _
"11111.... D" & @CRLF & _
"1111113.. E" & @CRLF & _
"111111111 F" & @CRLF & _
"111111111 G"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")