import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^.](?=\\.)";
final String string = "......... A\n"
+ "1........ B\n"
+ "112...... C\n"
+ "11111.... D\n"
+ "1111113.. E\n"
+ "111111111 F\n"
+ "111111111 G";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}