#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-+]?[0-9]*\.?[0-9]+([eE][-+]?[0-9]+)?$"
Local $sString = "So this should return characters for cases like" & @CRLF & _
"12.09a23" & @CRLF & _
"aa12.12" & @CRLF & _
"abcd" & @CRLF & _
"12.35"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")