re = /^[-+]?[0-9]*\.?[0-9]+([eE][-+]?[0-9]+)?$/m
str = 'So this should return characters for cases like
12.09a23
aa12.12
abcd
12.35'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end