re = /(?<=\[)[^\[\]]+(?=\])/
str = 'this is [[test]] line i [want] text [inside] square [brackets]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end