$re = '/(?<!\S)([0-9]+(?: [0-9]{1,3})?)€(?!\S)/m';
$str = '41 000€ à 63 000€ / an
41€';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);