re = /(?<!\S)([0-9]+(?: [0-9]{1,3})?)€(?!\S)/m
str = '41 000€ à 63 000€ / an
41€'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end