import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:0|[1-9]\\d*)?(?:\\.\\d+)?)\\s*\\b(rld[\\W_]*token|btcc|btc|ark|xmr|xrp)\\b";
final String string = "price of rldtoken\n"
+ "420 rld.token 0.28 btc\n"
+ "42.37 rldtoken to xrp\n"
+ "42.37rldtoken to xmr\n"
+ "cost of rldtoken\n"
+ "10 btc 12.47 rldtoken to xmr\n"
+ "whatisrldtoken\n"
+ "btcc price\n"
+ "btc cost\n"
+ "0.2btc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}