import re
regex = re.compile(r"((?:0|[1-9]\d*)?(?:\.\d+)?)\s*\b(rld[\W_]*token|btcc|btc|ark|xmr|xrp)\b", flags=re.MULTILINE)
test_str = ("price of rldtoken\n"
"420 rld.token 0.28 btc\n"
"42.37 rldtoken to xrp\n"
"42.37rldtoken to xmr\n"
"cost of rldtoken\n"
"10 btc 12.47 rldtoken to xmr\n"
"whatisrldtoken\n"
"btcc price\n"
"btc cost\n"
"0.2btc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")