# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)\w\w_\w\w(?:.*?)(?:(?:[&?]\w+=\d+|%\w*)*?(\?Id=\d+)(?:.*))?"
test_str = ("http://www.example.com/myplan/mp/public/pl_be?Id=543543×tamp=06280435435\n\n"
"http://www.example.com/course/df/public/pl_de%27?Id=454354×tamp=0628031746\n\n"
"http://www.example.com/book/rg/public/pl_fo?Id=4445577×tamp=0628031734\n\n"
"http://www.example.com/trip/tr/public/pl_ds&oisefejwf=02389283?anothaone=230023?somethingelse=2093432?Id=454354×tamp=06280314546\n\n"
"http://www.example.com/trip/tr/public/pl_ds\n\n"
"http://www.example.com/trip/tr/public/pl_ds?Id=454354×tamp=06280314546&bid=7667&source=ref\n\n"
"http://www.example.com/trip/tr/public/pl_ds?Id=454354%27")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.